Codeup——584 | 问题 E: FatMouse s Trade

题目描述

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

输入

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1’s. All integers are not greater than 1000.

输出

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

样例输入

4 2
4 7
1 3
5 5
4 8
3 8
1 2
2 5
2 4
-1 -1

样例输出

2.286
2.500

思路:可以用一个结构体来存放第i个仓库的食物还有需要用于交换的猫的食物,以及二者之间交换的比例。定义一个double型变量result,用于最后输出。输入完数据后,将此结构体按照 j/f 的比例从大到小进行排序,然后从比例最大的那个仓库开始进行交换即可。如果m大于第i个仓库所需要交换时的猫粮,则令result加上该仓库用于交换的食物,并且令m - f [ i ],否则就加上该仓库的交换比例与剩下m的积。

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;

struct food{
	double j;
	double f;
	double b;
}a[1000];

bool cmp(struct food a,struct food b){
	if(a.b==b.b) return a.j>b.j;
	else return a.b>b.b;
}

int main()
{
	int n,i;
	double m,result;
	while(scanf("%lf%d",&m,&n)!=EOF){
		if(m==-1&&n==-1)
			break;
		result=0;
		for(i=0;i<n;i++){
			cin >>a[i].j>>a[i].f;
			a[i].b=a[i].j/a[i].f;
		}
		sort(a,a+n,cmp);
		for(i=0;i<n;i++){
			if(m<=0)
				break;
			if(m>=a[i].f)
				result+=a[i].j;
			else
				result+=a[i].b*m;
			m-=a[i].f;	
		}
		printf("%.3lf\n",result);
	}
	return 0;
 } 

猜你喜欢

转载自blog.csdn.net/qq_44888152/article/details/106782001