D - Wireless Network(无线网络)

题意:给你 N 台坏了的电脑的坐标 ,和一个距离范围 d .

           (在距离范围内的电脑可以相互通信,每台电脑也可以连接两台不同的电脑,使他们之间能够通信)

           输入任意次数操作:

           O   x        表示修理好编号为 x 台的电脑

           S   x   y    判断电脑 x 和 y 是否能够通信 。能则 SUCCESS ,不能则 FAIL

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B. 

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations. 

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats: 
1. "O p" (1 <= p <= N), which means repairing computer p. 
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate. 

The input will not exceed 300000 lines. 

Output

For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL
SUCCESS
#include<cstdio>
#include <stdlib.h>
#include<cmath>
#include <iostream>
#include<cstring> 
#include <algorithm>
using namespace std;
const double esp = 1e-7;
const int maxn = 1000+10;
int p[maxn]; //父节点
int used[maxn]; //标记改点是否修理
int map[maxn][maxn]; //标记连通性
struct Point
{
    double x, y;
}point[maxn];
double dist(Point a, Point b)//在距离范围内的电脑可以相互通信
{
    return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
int find(int x)
{
    return x==p[x]?p[x]:find(p[x]);
}
int merge(int x,int y)
{
    int tx=find(x);
    int ty=find(y);
    if(tx!=ty) p[tx]=ty;
}
int main()
{
    int n,d;
    while(cin>>n>>d)//n台电脑,距离最长位d; 
    {
        memset(used,0,sizeof(used));
        memset(map,0,sizeof(map));
        for(int i=1;i<=n;i++)
        {
            cin>>point[i].x>>point[i].y;//坐标 
        }
        for(int i=1;i<=n;i++)
        {
            p[i]=i;//每一个父节点 
            map[i][i]=1;//从i到i; 
            for(int j=i+1;j<=n;j++)//从i到j 
                if(dist(point[i],point[j])-d<esp)    
                    map[i][j]=map[j][i]=1;
        }
        int x,y;
        getchar();
        char c;
        while(~scanf("%c",&c))
        {
            if(c=='O') 
            {
                scanf("%d",&x);
                if(!used[x])
                {    
                    used[x]=1;
                    for(int i=1;i<=n;i++)//依次判断 
                        if(used[i]&&map[i][x])
                            merge(x,i);
                }
            }
            else if(c == 'S')
            {
                scanf("%d%d", &x, &y);
                if(find(x) == find(y))
                printf("SUCCESS\n"); //连通
                else printf("FAIL\n"); //不连通
            }
        }
    }
}

猜你喜欢

转载自www.cnblogs.com/csx-zzh/p/13386729.html
今日推荐