H - Oil Skimming (挖石油)

题意大概是,海上漂浮着一些符号为#的石油,你要去搜集他们,但是你的勺子呢能且只能挖到两个单元的石油。问你最多能挖多少勺。注意 不能挖到纯净的海水,不然石油会被纯净的海水稀释的。

二分匹配,计算出里边有多少个‘#’,将这些编号,之后查找,如果他的周围是“#”,就将这两个连一条边。之后跑一边匈牙利;点数就是‘#’数目;

Thanks to a certain "green" resources company, there is a new profitable industry of oil skimming. There are large slicks of crude oil floating in the Gulf of Mexico just waiting to be scooped up by enterprising oil barons. One such oil baron has a special plane that can skim the surface of the water collecting oil on the water's surface. However, each scoop covers a 10m by 20m rectangle (going either east/west or north/south). It also requires that the rectangle be completely covered in oil, otherwise the product is contaminated by pure ocean water and thus unprofitable! Given a map of an oil slick, the oil baron would like you to compute the maximum number of scoops that may be extracted. The map is an NxN grid where each cell represents a 10m square of water, and each cell is marked as either being covered in oil or pure water.

InputThe input starts with an integer K (1 <= K <= 100) indicating the number of cases. Each case starts with an integer N (1 <= N <= 600) indicating the size of the square grid. Each of the following N lines contains N characters that represent the cells of a row in the grid. A character of '#' represents an oily cell, and a character of '.' represents a pure water cell.OutputFor each case, one line should be produced, formatted exactly as follows: "Case X: M" where X is the case number (starting from 1) and M is the maximum number of scoops of oil that may be extracted.Sample Input

1
6
......
.##...
.##...
....#.
....##
......

Sample Output

Case 1: 3
#include <stdio.h>
#include <iostream>
#include <string.h>
#include <algorithm>
using namespace std;
char  mp[650][650];
int g[650][650];
int vis[1000];
int dis[1000];
int dp[1000][1000];//新图的地图 
int n,t;
int v;//建立新图的边 
/* 匈 牙 利 算 法 */
int find(int x)
{
    for(int i=0;i<v;i++)
    {
        if(!vis[i]&&dp[x][i])
        {
            vis[i]=1;
            if(dis[i]==0||find(dis[i]))
            {
                dis[i]=x;
                return 1;
            }
         } 
    }
    return 0;
}
int maxp()
{
    int ans=0;
    memset(dis,0,sizeof(dis));
    for(int i=0;i<v;i++)
    {
        memset(vis,0,sizeof(vis));
        if(find(i))
        ans++;
    }
    return ans;
}
int main()
{
    int t,icase=1;
    cin>>t;
    while(t--)
    {
        cin>>n;
        int cnt=0,ans=0;
        memset(mp,0,sizeof(mp));
        memset(dp,0,sizeof(dp));
        for(int i=0;i<n;i++)
        {    
            scanf("%s",mp[i]);
            for(int j=0;j<n;j++)
            {    
                if(mp[i][j]=='#')//
                    g[i][j]=cnt++;
            }
        }
        v=cnt;//新图的边 
        for(int i=0;i<n;i++)/*保存新图,即将题给的图转换成点与点之间边的关系*/
        {
            for(int j=0;j<n;j++)
            {
                if(mp[i][j]!='#') continue;
                if(i>0&&mp[i-1][j]=='#') dp[g[i-1][j]][g[i][j]]=1;
                if(i<n-1&&mp[i+1][j]=='#') dp[g[i+1][j]][g[i][j]]=1;
                if(j>0&&mp[i][j-1]=='#') dp[g[i][j-1]][g[i][j]]=1;
                if(j<n-1&&mp[i][j+1]=='#') dp[g[i][j+1]][g[i][j]]=1;
            }
        }
        ans=maxp();
        printf("Case %d: %d\n",icase++,ans/2);
    }
}

猜你喜欢

转载自www.cnblogs.com/csx-zzh/p/13394511.html
今日推荐