Codeup——596 | 问题 B: Student List for Course (25)

题目描述

Zhejiang University has 40000 students and provides 2500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.

输入

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=40000), the total number of students, and K (<=2500), the total number of courses. Then N lines follow, each contains a student’s name (3 capital English letters plus a one-digit number), a positive number C (<=20) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.

输出

For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students’ names in alphabetical order. Each name occupies a line.

样例输入

10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5

样例输出

1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1

思路:这个题和上一个题刚刚好相反,我们可以定义一个char型的二维数组,用于存放学生姓名,再把姓名的下标散列到vector型的课程号里,然后对每个课程里的学生姓名进行排序。

#include <iostream>
#include <cstdio>
#include <vector>
#include <cstring>
#include <algorithm>
using namespace std;

vector<int> course[2501];
char name[40000][5];

bool cmp(int a,int b){
    
    	//按姓名递增排序
	return strcmp(name[a],name[b])<0;
}

int main()
{
    
    
	int i,j,n,m,cnt,cns;
	scanf("%d%d\n",&n,&m);	//输入总人数与总课程数
	for(i=0;i<n;i++){
    
    
		scanf("%s",name[i]);	//输入学生姓名
		scanf("%d",&cnt);	//输入所选课程总数
		for(j=0;j<cnt;j++){
    
    	
			scanf("%d",&cns);	//输入课程号
			course[cns].push_back(i);	//将学生姓名的下标存放课程号里
		}
	}
	for(i=1;i<=m;i++){
    
    
		int s=course[i].size();
		printf("%d %d\n",i,s);
		sort(course[i].begin(),course[i].end(),cmp);
		for(j=0;j<s;j++){
    
    
			printf("%s\n",name[course[i][j]]);
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_44888152/article/details/106982852