PAT甲级 A1037 Magic Coupon (25分) ---(题目 + 代码 + 详细注释)

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!

For example, given a set of coupons { 1 2 4 −1 }, and a set of product values { 7 6 −2 −3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons N​C​​, followed by a line with N​C​​ coupon integers. Then the next line contains the number of products N​P​​, followed by a line with N​P​​ product values. Here 1≤N​C​​,N​P​​≤10​5​​, and it is guaranteed that all the numbers will not exceed 2​30​​.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:

4
1 2 4 -1
4
7 6 -2 -3

Sample Output:

43

//题目大意是:在两个集合里,选择相同数量的数分别相乘再求和,要求找出和的最大值

//思想分析:典型的贪心。首先,显然两数要同号(如果异号的话,相乘的结果为负,只会拉低最后求得的和);其次,用绝对值大的数乘以绝对值大的数。下面以整数为例简单证明下:

因此呢,要分两部分求,结果 = 负数 * 负数 + 正数 * 正数

下面是我AC的代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
int C[100005], P[100005];    //C数组是第一个数组,P是第二个

int main() {
	int n, m;
	cin >> n;
	for (int i = 0; i < n; i++)
		cin >> C[i];             //读入第一个集合
	cin >> m;
	for (int i = 0; i < m; i++)
		cin >> P[i];          //读入第二个集合
	sort(C, C + n);            //对两个数组从小到大排列
	sort(P, P + m);
	int ans = 0;
//正数 * 正数 部分,逆序遍历数组
	for (int i = n - 1, j = m - 1; i >= 0, j >= 0; i--, j--)        
		if (C[i] < 0 || P[j] < 0)       //若有一个为负则此部分结束,0对结果无影响,故不用考虑   
			break;
		else
			ans += C[i] * P[j];
//负数 * 负数 部分,顺序遍历数组
	for (int i = 0, j = 0; i < n, j < m; i++, j++)
		if (C[i] > 0 || P[j] > 0)       //发现有一个为正数,则停止
			break;
		else
			ans += C[i] * P[j];
	cout << ans << endl;               //输出结果
	return 0;
}

//最后,先看后好习惯噢!!

猜你喜欢

转载自blog.csdn.net/qq_45472866/article/details/104754294
今日推荐