电话聊天狂人 (25分)(map做法,散列不会)

给定大量手机用户通话记录,找出其中通话次数最多的聊天狂人。

输入格式:
输入首先给出正整数N(≤10​5),为通话记录条数。随后N行,每行给出一条通话记录。简单起见,这里只列出拨出方和接收方的11位数字构成的手机号码,其中以空格分隔。

输出格式:
在一行中给出聊天狂人的手机号码及其通话次数,其间以空格分隔。如果这样的人不唯一,则输出狂人中最小的号码及其通话次数,并且附加给出并列狂人的人数。

输入样例:

4
13005711862 13588625832
13505711862 13088625832
13588625832 18087925832
15005713862 13588625832

输出样例:

13588625832 3

散列没学,商量无脑map,提交了很多遍,一直12分(一共就仨测试点,只过了一个),后来发现是题意理解错了。得先找出最大值之后才能看有没有并列的。。有并列的不是发现了就没事了,还得统计有多少个一样的,包括它自己
#include <iostream> 
#include <map> 
#include <algorithm>
using namespace std;

int main(){
    
    
	ios::sync_with_stdio(false);
	cin.tie(0),cout.tie(0);
	map<string,int> m;
	int n;
	cin >> n;
	string s1,s2;
	for(int i = 0;i<n;i++){
    
    
		cin >> s1 >> s2;
		m[s1]++;
		m[s2]++;
	}
	int maxn = 0;
    int cnt = 0;
    string res;
	for(auto it = m.begin();it!=m.end();it++){
    
    
		if(it->second>maxn){
    
    
			maxn = it->second;
			res = it->first;
		}
	}
    for(auto it = m.begin();it!=m.end();it++){
    
    
		if(it->second==maxn){
    
    
			cnt++;
		}
	}
    if(cnt==1)
	    cout << res << " " << maxn;
    else
        cout << res << " " << maxn << " " << cnt;
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_45845039/article/details/108772442
今日推荐