POJ - 2325 Persistent Numbers

The multiplicative persistence of a number is defined by Neil Sloane (Neil J.A. Sloane in The Persistence of a Number published in Journal of Recreational Mathematics 6, 1973, pp. 97-98., 1973) as the number of steps to reach a one-digit number when repeatedly multiplying the digits. Example:
679 -> 378 -> 168 -> 48 -> 32 -> 6.

That is, the persistence of 679 is 6. The persistence of a single digit number is 0. At the time of this writing it is known that there are numbers with the persistence of 11. It is not known whether there are numbers with the persistence of 12 but it is known that if they exists then the smallest of them would have more than 3000 digits.
The problem that you are to solve here is: what is the smallest number such that the first step of computing its persistence results in the given number?
Input
For each test case there is a single line of input containing a decimal number with up to 1000 digits. A line containing -1 follows the last test case.
Output
For each test case you are to output one line containing one integer number satisfying the condition stated above or a statement saying that there is no such number in the format shown below.
Sample Input
0
1
4
7
18
49
51
768
-1
Sample Output
10
11
14
17
29
77
There is no such number.
2688

题意描述:给出一个数,让你求出另外一个数他的每一位相乘等于此数,并且是最小的
679 -> 378 -> 168 -> 48 -> 32 -> 6
前一个数的各位数字的乘积等于下一个数。
在这里插入图片描述

解题思路:

最直接的想法就是将该数按从大到小的顺序分解因子。即按9,8,7,6,5,4,3,2的顺序,每个数都试除,如果该数可除,则继续尝试到不能被该数整除为止!最后将所有因子按从小到大的顺序输出即可。

AC代码

#include<stdio.h>
#include<string.h>
int l;
char a[1100];
int b[1000020];
int kk(int n)
{
    
    
    int i,j,sum=0,t[1100];
    for(i=0;i<l;i++)//大数除法 //模拟除法运算过程 
    {
    
    
        sum=a[i]+sum*10;
        t[i]=sum/n;
         sum=sum%n;
    }
    if(sum)
        return 0;
    int k = 0;
    while(t[k]==0)
	k++;
	l=l-k;
    for(i=0;i<l;i++)
        a[i]=t[k++];
    return 1;
}
int main()
{
    
    
    while(scanf("%s",&a)!=EOF)
    {
    
    
		if(a[0]=='-'&&a[1]=='1')//输入-1结束 
            break;
         l=strlen(a);
         if(l==1)//输入为一个数字的时候 
        {
    
    
        	printf("1%s\n",a);
        	continue;
		}
        int k=0;
         for(int i=0;i<l;i++)
            a[i]-='0';
            for(int i=9;i>=2;i--)
               while(kk(i))//判断能否满足整除 
                   b[k++]=i;
            if(l!=1)//没能被除尽 
            {
    
    
            	printf("There is no such number.\n");
            	continue;
			}
            if(k==1)//因子是1和本身
            {
    
    
				b[k++]=1;
            }
			for(int i=k-1;i>=0;i--)
	                printf("%d",b[i]);
	            printf("\n");
    }
}

猜你喜欢

转载自blog.csdn.net/weixin_46703995/article/details/113063428