7-6 输出GPLT (20分)

给定一个长度不超过10000的、仅由英文字母构成的字符串。请将字符重新调整顺序,按GPLTGPLT…这样的顺序输出,并忽略其它字符。当然,四种字符(不区分大小写)的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按GPLT的顺序打印,直到所有字符都被输出。
输入格式:

输入在一行中给出一个长度不超过10000的、仅由英文字母构成的非空字符串。

输出格式:

在一行中按题目要求输出排序后的字符串。题目保证输出非空。

输入样例:

pcTclnGloRgLrtLhgljkLhGFauPewSKgt

输出样例:

GPLTGPLTGLTGLGLL

很简单,一看就会

#include <iostream>
#include <string>
#include<algorithm>
#include<bits/stdc++.h>
#include<stack>
using namespace std;

int main() {
    
    
    string s;
    getline(cin,s);
    int i;
    int sumG=0,sumP=0,sumL=0,sumT=0;
    for(i=0;s[i]!='\0';i++){
    
    
    	if(s[i]=='G'||s[i]=='g'){
    
    
    		sumG++;
		}
		else if(s[i]=='T'||s[i]=='t'){
    
    
			sumT++;
		}
		else if(s[i]=='l'||s[i]=='L'){
    
    
			sumL++;
		}
		else if(s[i]=='P'||s[i]=='p'){
    
    
			sumP++;
		}
	}
    while(sumP||sumL||sumT||sumG){
    
    
    	if(sumG>0){
    
    
    		cout<<"G";
    		sumG--;
		}
		if(sumP>0){
    
    
    		cout<<"P";
    		sumP--;
		}
		if(sumL>0){
    
    
    		cout<<"L";
    		sumL--;
		}
		if(sumT>0){
    
    
    		cout<<"T";
    		sumT--;
		}
	}
}

猜你喜欢

转载自blog.csdn.net/weixin_45962741/article/details/112810029
今日推荐