1020 Tree Traversals (25分)
Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.
Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:
4 1 6 3 5 7 2
#include <iostream>
#include<cstdio>
#include<algorithm>
#include<string.h>
#include<string>
#include<stack>
#include<cmath>
#include<map>
#include<queue>
using namespace std;
#pragma warning(disable:4996)
const int maxn = 35;
struct node {
int data;
struct node* lchild;
struct node* rchild;
};
int n, post[maxn], in[maxn];
node* create(int postl, int postr, int inl, int inr) {
if (postl > postr)return NULL;
node* root = new node;
root->data = post[postr];
int k;
for (k = inl; k <= inr; k++) {
if (in[k] == post[postr])
break;
}
int numleft = k - inl;
root->lchild = create(postl, postl + numleft - 1, inl, k - 1);
root->rchild = create(postl + numleft, postr - 1, k + 1, inr);
return root;//一开始这里忘记返回了
}
void level(node* root) {
queue<node*> q;
q.push(root);
int flag = 1;
while (!q.empty()) {
node* temp = q.front();
q.pop();
if (flag == 1) {
printf("%d", temp->data);
flag = 0;
}
else {
printf(" %d", temp->data);
}
if (temp->lchild)q.push(temp->lchild);
if (temp->rchild)q.push(temp->rchild);
}
}
int main() {
scanf("%d", &n);
for (int i = 0; i < n; i++)
scanf("%d", &post[i]);
for (int i = 0; i < n; i++)
scanf("%d", &in[i]);
node* root = create(0, n - 1, 0, n - 1);
level(root);
return 0;
}