1044 火星数字 (20分)
火星人是以 13 进制计数的:
- 地球人的 0 被火星人称为 tret。
- 地球人数字 1 到 12 的火星文分别为:jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec。
- 火星人将进位以后的 12 个高位数字分别称为:tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou。
例如地球人的数字 29
翻译成火星文就是 hel mar
;而火星文 elo nov
对应地球数字 115
。为了方便交流,请你编写程序实现地球和火星数字之间的互译。
输入格式:
输入第一行给出一个正整数 N(<100),随后 N 行,每行给出一个 [0, 169) 区间内的数字 —— 或者是地球文,或者是火星文。
输出格式:
对应输入的每一行,在一行中输出翻译后的另一种语言的数字。
输入样例:
4
29
5
elo nov
tam
输出样例:
hel mar
may
115
13
算法笔记:
#include<cstdio>
#include<algorithm>
#include<string>
#include<queue>
#include<string.h>
#include<iostream>
#include<set>
#include<map>
using namespace std;
//16:07
string low[13]={"tret","jan", "feb", "mar", "apr", "may",
"jun", "jly", "aug", "sep", "oct", "nov", "dec"};
string high[13]={"tret","tam", "hel", "maa", "huh", "tou", "kes",
"hei", "elo", "syy", "lok", "mer", "jou"};
map<string,int> mp;
string num_to_str[170];
void init(){
for(int i=0;i<13;i++){
num_to_str[i]=low[i];
mp[low[i]]=i;
num_to_str[i*13]=high[i];
mp[high[i]]=i*13;
}
for(int i=1;i<13;i++){
for(int j=1;j<13;j++){
string tmp=high[i]+" "+low[j];
//cout<<"tmp:"<<tmp<<"**"<<13*i+j<<endl;
mp[tmp]=i*13+j;
num_to_str[i*13+j]=tmp;
}
}
//for(int i=0;i<70;i++)
//cout<<i<<" "<<num_to_str[i]<<endl;
}
int main(){
init();
int n;
scanf("%d\n",&n);
while(n--){
string s;
getline(cin,s);
if(s[0]>='0'&&s[0]<='9'){
int num=0;
for(int i=0;i<s.length();i++)
num=num*10+(s[i]-'0');
cout<<num_to_str[num]<<endl;
}
else{
printf("%d\n",mp[s]);
}
}
return 0;
}
这个强!:
#include <iostream>
#include <string>
using namespace std;
string a[13] = {"tret", "jan", "feb", "mar", "apr", "may", "jun", "jly", "aug", "sep", "oct", "nov", "dec"};
string b[13] = {"####", "tam", "hel", "maa", "huh", "tou", "kes", "hei", "elo", "syy", "lok", "mer", "jou"};
string s;
int len;
void func1(int t) {
if (t / 13) cout << b[t / 13];
if ((t / 13) && (t % 13)) cout << " ";
if (t % 13 || t == 0) cout << a[t % 13];
}
void func2() {
int t1 = 0, t2 = 0;
string s1 = s.substr(0, 3), s2;
if (len > 4) s2 = s.substr(4, 3);
for (int j = 1; j <= 12; j++) {
if (s1 == a[j] || s2 == a[j]) t2 = j;
if (s1 == b[j]) t1 = j;
}
cout << t1 * 13 + t2;
}
int main() {
int n;
cin >> n;
getchar();
for (int i = 0; i < n; i++) {
getline(cin, s);
len = s.length();
if (s[0] >= '0' && s[0] <= '9')
func1(stoi(s));
else
func2();
cout << endl;
}
return 0;
}