Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
Sample Input
2 1 2 112233445566778899 998877665544332211
Sample Output
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
#include<iostream>
#include<string>
using namespace std;
int main()
{
int p,A,B,num=1,sum[1000];
string a, b;
cin >> p;
while (p--)
{
int m=0, n=0, k = 0, temp=0;
cin>>a>>b;
A = a.length();
B = b.length();
A -= 1;
B -= 1;
while (A>=0&&B>=0)
{
m =a[A]-'0';
n =b[B]-'0';
sum[k++] = (m+n+temp)%10;
temp = (m+n+temp)/10;
A--;
B--;
}
if (A > B)
{
while (A>=0)
{
n = a[A] - '0';
sum[k++] = (n+temp) % 10;
temp = (n+temp) / 10;
A--;
}
}
if (A<B)
{
while (B>=0)
{
n = b[B] - '0';
sum[k++] = (n + temp) % 10;
temp = (n + temp) / 10;
B--;
}
}
sum[k] = temp;
cout << "Case " << num << ':' << endl;
cout << a <<" + "<<b << " = ";
num++;
for(int i=k-1;i>0;i--)
{
cout << sum[i];
}
cout << sum[0]<<endl;
if (p !=0) cout << endl;
}
return 0;
}