1029 Median (25 point(s))

思路:

计算的出中位数的位置,然后比较两个数组,得出中位数,时间复杂度为 O(n+m)

1029 Median (25 point(s))

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (≤2×10​5​​) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

Output Specification:

For each test case you should output the median of the two given sequences in a line.

Sample Input:

4 11 12 13 14
5 9 10 15 16 17

Sample Output:

13

Example:

#include<iostream>
#include<vector>
using namespace std;

vector<long> *input(void)
{
    int N;
    cin >> N;
    vector<long> *p = new vector<long>(N);
    for(int i = 0; i < N; i++) cin >> (*p)[i];
    return p;
}

int main()
{
    vector<long> *L1 = input();
    vector<long> *L2 = input();
    int m, i, j, mean = ( L1->size() + L2->size()+1) / 2;
    for(i = 0, j = 0; i < L1->size() && j < L2->size() && mean; mean--)
        if((*L1)[i] <= (*L2)[j]) m = (*L1)[i++];
        else m = (*L2)[j++];
    if(mean)
        if(i == L1->size()) m = (*L2)[j+mean-1];
        else m = (*L1)[i+mean-1];
    cout << m << endl;
}

猜你喜欢

转载自blog.csdn.net/u012571715/article/details/114111236