1028 List Sorting (25 point(s))

思路:

利用 map 处理不同条件,若条件相同,则利用 set 处理。

1028 List Sorting (25 point(s))

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input Specification:

Each input file contains one test case. For each case, the first line contains two integers N (≤10​5​​) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student's record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output Specification:

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID's; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID's in increasing order.

Sample Input 1:

3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1:

000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2:

4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample Output 2:

000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3:

4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90

Sample Output 3:

000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90

Example:

#include<iostream>
#include<cstdio>
#include<map>
#include<set>
using namespace std;

int main()
{
    int N, C;
    cin >> N >> C;
    map<int, pair<string, string>> Record;
    map<string, set<int>> Cond;
    for(int i = 0; i < N; i++) {
        string name, grade;
        int id;
        cin >> id >> name >> grade;
        Record.emplace(id, make_pair(name, grade));
        if(C == 2) Cond[name].emplace(id);
        else if(C == 3) Cond[grade].emplace(id);
    }
    if(C == 1)
        for(auto &x : Record) {
            printf("%06d ", x.first);
            cout << x.second.first << ' ' << x.second.second << endl;
        }
    else 
        for(auto &x : Cond) {
            for(auto &y : x.second) {
                printf("%06d ", y);
                cout << Record[y].first << ' ' << Record[y].second << endl;
            }
        }
}

猜你喜欢

转载自blog.csdn.net/u012571715/article/details/114106712