1027 Colors in Mars (20 point(s))

思路:

模13和整除13的数学题。

1027 Colors in Mars (20 point(s))

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input Specification:

Each input file contains one test case which occupies a line containing the three decimal color values.

Output Specification:

For each test case you should output the Mars RGB value in the following format: first output #, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a 0 to its left.

Sample Input:

15 43 71

Sample Output:

#123456

Example:

#include<iostream>
#include<algorithm>

using namespace std;

char solve(int a)
{
    return a <= 9 ? a + '0' : a-10 + 'A';
}

int main()
{
    int N[3];
    for(int i = 0; i < 3; i++) cin >> N[i];
    string out("#");
    for(int i = 0; i < 3; i++) {
        out.push_back(solve(N[i] / 13));
        out.push_back(solve(N[i] % 13));
    }
    cout << out;
}

猜你喜欢

转载自blog.csdn.net/u012571715/article/details/114097288