1023 Have Fun with Numbers (20 point(s))

思路:

从后往前访问字符串,乘以2后入栈,统计相应 digit 出现的次数;

计算栈的 digit 统计出现次数,如果两者不相同,则输出 No,否则输出 Yes

最后输出翻倍后的字符串。

1023 Have Fun with Numbers (20 point(s))

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

Sample Output:

Yes
2469135798

Example:

#include<iostream>
#include<vector>

using namespace std;

int main()
{
    string N, Double;
    cin >> N;
    vector<int> Count(10, 0);
    int ans = 0;
    for(auto x = N.rbegin(); x != N.rend(); x++) {
        Count[*x-'0']++;
        ans += (*x - '0') * 2;
        Double.push_back(ans%10 + '0');
        ans /= 10;
    }
    if(ans != 0) Double.push_back(ans%10 + '0');
    for(auto &x : Double) Count[x-'0']--;
    bool Yes = true;
    for(auto &x : Count) if(x != 0) Yes = false;
    cout << (Yes ? "Yes\n" : "No\n");
    for(auto x = Double.rbegin(); x != Double.rend(); x++) cout << *x;
}

猜你喜欢

转载自blog.csdn.net/u012571715/article/details/114062920