5.4 PAT A1078 Hashing (25分)(hash表实现)

1078 Hashing (25分)

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (≤10​4​​) and N (≤MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print "-" instead.

Sample Input:

4 4
10 6 4 15

Sample Output:

0 1 4 -

此题实质是hash表的实现。注意此题处理冲突的方法是 Quadratic probing (with positive increments only) 即二次探查法,但只计算正增长。

参考代码:

#include <cstdio>
#include <cmath>
#include <cstring> 
bool isprime(int n)
{
	int sqr=(int)sqrt(1.0*n);
	if(n==1)
		return false;
	for(int i=2;i<=sqr;++i)
	{
		if(n%i==0)
			return false;
	}
	return true;
} 
bool p[10010]; //记录位置i处是否已插入元素 
int main() 
{
	int m,n,a,pos;
	while(scanf("%d%d",&m,&n)!=EOF)
	{
		memset(p,0,sizeof(p)); 
		while(!isprime(m))
		{
			m++; //寻找大于m的最小素数 
		}
		for(int i=0;i<n;++i)
		{
			scanf("%d",&a);
			pos=a%m;
			bool flag=false; //记录是否插入成功 
			if(p[pos]==false)
			{
				flag=true; //有位置,插入成功 
				p[pos]=true;
			}
			else
			{
				for(int i=1;i<m;i++) //处理冲突,寻找后续位置 
				{
					pos=(a+i*i)%m; //二次方探查,只计算正增长 
					if(p[pos]==false)
					{
						flag=true;
						p[pos]=true;
						break;
					}
				}
			}
			if(flag)
				printf("%d",pos);
			else
				printf("-");
			if(i<n-1)
				printf(" ");
		}
		printf("\n");	
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_43590614/article/details/105179860