1015 Reversible Primes (20分)
A reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.
Now given any two positive integers N (<105) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.
Input Specification:
The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.
Output Specification:
For each test case, print in one line Yes
if N is a reversible prime with radix D, or No
if not.
Sample Input:
73 10
23 2
23 10
-2
Sample Output:
Yes
Yes
No
题意为判断将素数转换为d进制后反转是否还是素数 。注意1要特判,否则会有一组错误。
参考代码:
#include<cstdio>
#include <cmath>
bool isprime(int n)
{
if(n<=1) //注意n==1时要特判为返回false
return false;
int sqr=(int)sqrt(1.0*n);
for(int i=2;i<=sqr;++i)
{
if(n%i==0)
return false;
}
return true;
}
int change(int n,int a)
{
int b,ans=0;
do{
b=n%a;
n/=a;
ans=ans*a+b; //反转+转回十进制
}while(n);
return ans;
}
int main()
{
int n,d;
while(scanf("%d",&n)&&n>=0)
{
scanf("%d",&d);
int b=change(n,d);
if(isprime(n)&&isprime(b))
printf("Yes\n");
else
printf("No\n");
}
return 0;
}