codeup|问题 F: 数组逆置

题目描述
输入一个字符串,长度小于等于200,然后将数组逆置输出。

输入
测试数据有多组,每组输入一个字符串。

输出
对于每组输入,请输出逆置后的结果。

样例输入 Copy
tianqin
样例输出 Copy
niqnait
提示
注意输入的字符串可能会有空格。
(注:有空格意味着需要用gets而不是scanf进行输入)

代码

#include<stdio.h>
#include<string.h>

int main() {
    
    
    char s[300];
    while (gets(s) != NULL) {
    
    
        for (int i = strlen(s) - 1; i >= 0; i--) {
    
    
            printf("%c", s[i]);
        }
        printf("\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43340821/article/details/114003566