Minesweeper
题目:
Minesweeper Have you ever played Minesweeper? This cute little game comes with a certain operating system whose name we can’t remember. The goal of the game is to find where all the mines are located within a M x N field. The game shows a number in a square which tells you how many mines there are adjacent to that square. Each square has at most eight adjacent squares. The 4 x 4 field on the left contains two mines, each represented by a ``*’’ character. If we represent the same field by the hint numbers described above, we end up with the field on the right: … … .… … 100 2210 110 1110
中文翻译:
你玩过扫雷吗?游戏的目标是找出所有的地雷都在一个M×N的区域内。游戏在一个正方形中显示一个数字,它告诉你在这个正方形附近有多少地雷。每个方块最多有八个相邻方块。左边的4x4字段包含两个地雷,每个地雷由一个`'字符表示。如果我们用上面描述的提示数字来表示同一个字段,那么右边的字段就是:。… … 100 2210 110 1110
输入:
The input will consist of an arbitrary number of fields. The first line of each field contains two integers n and m ( 0 < n, m$ \le$100) which stand for the number of lines and columns of the field, respectively. Each of the next n lines contains exactly m characters, representing the field. Safe squares are denoted by .'' and mine squares by
*,’’ both without the quotes. The first field line where n = m = 0 represents the end of input and should not be processed.
中文翻译:
输入将由任意数量的字段组成。每个字段的第一行包含两个整数n和m(0<n,m$\le$100),分别表示字段的行数和列数。接下来的n行中的每一行正好包含m个字符,表示字段。安全方块用“.”表示,我的方块用`*,”表示,两者都没有引号。n=m=0的第一个字段行表示输入结束,不应进行处理。
输出:
For each field, print the message Field #x: on a line alone, where x stands for the number of the field starting from 1. The next n lines should contain the field with the ``.’’ characters replaced by the number of mines adjacent to that square. There must be an empty line between field outputs.
中文翻译:
对于每个字段,只打印一行消息字段#x:其中x代表从1开始的字段编号。接下来的n行应该包含带有“.”字符的字段,替换为与该正方形相邻的地雷数量。字段输出之间必须有空行。
样例输入:
4 4
…
…
.…
…
3 5
**…
…
.*…
0 0
样例输出:
Field #1:
100
2210
110
1110
Field #2:
**100
33200
1*100
AC代码:
#include<stdio.h>
#include<string.h>
int n,m;
char a[110][110];
int num[110][110];
int to[8][2]= {
{
-1,-1},{
-1,0},{
-1,1},{
0,1},{
1,1},{
1,0},{
1,-1},{
0,-1}};
void bfs(int x,int y)
{
//把地雷往八个方向扩散
int tx,ty;
int i;
for(i=0; i<8; i++)
{
tx=x+to[i][0];
ty=y+to[i][1];
if(tx>=0&&ty>=0&&tx<n&&ty<m&&a[tx][ty]!='*')
num[tx][ty]++;
}
}
int main()
{
int id=1;
while(~scanf("%d%d",&n,&m)&&n&&m)
{
memset(num,0,sizeof(num));
int i,j;
for(i=0; i<n; i++)
scanf("%s",a[i]);
for(i=0; i<n; i++)
{
for(j=0; j<m; j++)
{
if(a[i][j]=='*')
bfs(i,j);
}
}
printf("Field #%d:\n",id++);
for(i=0; i<n; i++)
{
for(j=0; j<m; j++)
{
if(a[i][j]=='*')
printf("*");
else
printf("%d",num[i][j]);
}
printf("\n");
}
printf("\n");
}
return 0;
}