7-11 后缀式求值!!!不会

7-11 后缀式求值 (25分)

我们人类习惯于书写“中缀式”,如 3 + 5 * 2 ,其值为13。 (p.s. 为什么人类习惯中缀式呢?是因为中缀式比后缀式好用么?)
而计算机更加习惯“后缀式”(也叫“逆波兰式”,Reverse Polish Notation)。上述中缀式对应的后缀式是: 3 5 2 * +
现在,请对输入的后缀式进行求值。

输入格式:

在一行中输入一个后缀式,运算数和运算符之间用空格分隔,运算数长度不超过6位,运算符仅有+ - * / 四种。

输出格式:

在一行中输出后缀式的值,保留一位小数。

输入样例:

3 5.4 2.2 * +

输出样例:

14.9

AC

表达式的题目就是我的噩梦啊!!!
很久都不会写啊
到现在还要找答案
我真的是太难了啊啊啊啊啊啊啊啊啊啊啊

#include<bits/stdc++.h>
#include <iostream>
#include <algorithm>
#include <stack>
#include <string>
using namespace std;

int main() {
    
    
	string c,t;
	getline(cin,c);
	stack<double> s;
	double a,b;
	int i=0;
	while(i<c.length()) {
    
    
		int j=i;
		while(j<c.length()&&c[j]!=' ')
			j++;
		t=c.substr(i,j-i);
		i=j+1;

		if(t=="+") {
    
    
			a=s.top();
			s.pop();
			b=s.top();
			s.pop();
			s.push(a+b);
		} else if(t=="-") {
    
    
			a=s.top();
			s.pop();
			b=s.top();
			s.pop();
			s.push(b-a);
		} else if(t=="*") {
    
    
			a=s.top();
			s.pop();
			b=s.top();
			s.pop();
			s.push(b*a);
		} else if(t=="/") {
    
    
			a=s.top();
			s.pop();
			b=s.top();
			s.pop();
			if(a==0)
				return 0;
			else
				s.push(b/a);
		} else
			s.push(stod(t));
	}
	printf("%.1lf",s.top());
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_45745322/article/details/112793870