6.2 问题 A: Set Similarity (25)

题目描述

Given two sets of integers, the similarity of the sets is defined to be Nc/Nt*100%, where Nc is the number of distinct common numbers shared by the two sets, and Nt is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

输入

Each input file contains one test case. Each case first gives a positive integer N (<=50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (<=104) and followed by M integers in the range [0, 109]. After the input of sets, a positive integer K (<=2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.

输出

For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

样例输入 Copy

3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3

样例输出 Copy

50.0%
33.3%
#include <iostream>
#include <cstdio>
#include <set>
using namespace std;
int main()
{
    set<int> s[100];
    int n,m,x,y;
    scanf("%d",&n);
    for(int i=1;i<=n;i++){
        scanf("%d",&m);
        while(m--){
            scanf("%d",&x);
            s[i].insert(x);
        }
    }
    scanf("%d",&m);
    while(m--){
        scanf("%d %d",&x,&y);
        int cnt=0;
        set<int>::iterator it1=s[x].begin(),it2=s[y].begin();
        while(it1!=s[x].end()&&it2!=s[y].end()){
            if(*it1==*it2){
                cnt++;
                it1++;
                it2++;
            }
            else if(*it1>*it2) it2++;
            else it1++;
        }
        double ans=(double)cnt/(double)(s[x].size()+s[y].size()-cnt);
        printf("%.1lf%%\n",ans*100);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/wangws_sb/article/details/114678283
今日推荐