OJ problem 3493 FileStream读文件

题目描述

使用FileStream类,编写一个控制台应用,能够读取当前文件夹下myFile.dic文件内容,并在屏幕上显示。

输入

输出

文件内容

样例输入

copy

样例输出

hello world!

hi ,good

首先,创建myFile.dic文件(否则运行时出现找不到文件,出现错误),文件内容为样例输出所示,将文件保存在当前文件夹下,修改copy to output directory属性为copy if newer

以下为参考代码:

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;
using System.IO;

namespace ConsoleApplication1
{
    class Program
    {
        static void Main(string[] args)
        {
            string path="myFile.dic";
            FileStream fs = new FileStream(path, FileMode.Open, FileAccess.Read);
            //long i = fs.Length;
            byte[] b = new byte[fs.Length];
            fs.Read(b, 0, b.Length);
            fs.Dispose();

            UTF8Encoding tmp = new UTF8Encoding();
            Console.WriteLine(tmp.GetString(b));
            Console.ReadKey();
        }
    }
}

猜你喜欢

转载自blog.csdn.net/wangws_sb/article/details/106220195
今日推荐