OJ Problem 3446 C#统计字符出现的个数

题目描述

编写一个实例方法getCountChar方法。该方法参数有两个,第一个参数可以是字符串s,第二个参数为字符c,方法返回值为第二个参数在第一个参数中出现次数。例如,CountChar("6221982",'2')返回值为3。 
部分程序代码已经给出。 
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;
namespace ConsoleApplication1
{
    class Program
    {
        static void Main(string[] args)
        { 
            string str = Console.ReadLine();     
            char ch = (char) Console.Read();
            Program pro = new Program();
            Console.WriteLine(pro.getCountChar(str,ch));
            //Console.ReadKey();
        }
        public int getCountChar(String s,char c){
        // 
        在此处填写代码
        // 
        }
    }
}

提交时,请提交整个题目!!! 

输入

一个字符串s,一个字符c

输出

该字符c在字符串s中的出现次数

样例输入

6221982
2

样例输出

3
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;
using System.Security.Cryptography;
using System.IO;
namespace ConsoleApplication1
{
    class Program
    {
        static void Main(string[] args)
        {
            string str = Console.ReadLine();
            char ch = (char)Console.Read();
            Program pro = new Program();
            Console.WriteLine(pro.getCountChar(str, ch));
            //Console.ReadKey();
        }
        public int getCountChar(String s,char c){
            int count = 0;
            for (int i = 0; i < s.Length; i++)
            {
                if (s[i] == c)
                {
                    count++;
                }
            }
            return count;
        }
    }
} 

猜你喜欢

转载自blog.csdn.net/wangws_sb/article/details/105112028
今日推荐