题目
Problem Description
A number sequence is defined as follows:
f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.
Given A, B, and n, you are to calculate the value of f(n).
Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
Output
For each test case, print the value of f(n) on a single line.
Sample Input
1 1 3
1 2 10
0 0 0
Sample Output
2
5
1.代码
代码如下(示例):
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<cmath>
using namespace std;
/*
这题两个数相加后在对7取模,所以就有7*7=49种情况,所以循环周期应该为49
*/
int f[55];
int main()
{
int a,b,n;
f[1]=f[2]=1;
while(scanf("%d%d%d",&a,&b,&n)==3)
{
if(a==0&&b==0&&n==0) break;
for(int i=3;i<=50;i++)
{
f[i]=(a*f[i-1]+b*f[i-2])%7;
}
printf("%d\n",f[n%49]);
}
return 0;
}