Problem Description:
This time your job is to fill a sequence of N N N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upper-left corner, then move in a clockwise spiral. The matrix has m m m rows and n n n columns, where m m m and n n n satisfy the following: m × n m\times n m×n must be equal to N N N; m ≥ n m\geq n m≥n; and m − n m−n m−n is the minimum of all the possible values.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N N N. Then the next line contains N N N positive integers to be filled into the spiral matrix. All the numbers are no more than 1 0 4 10^4 104. The numbers in a line are separated by spaces.
Output Specification:
For each test case, output the resulting matrix in m lines, each contains n numbers. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.
Sample Input:
12
37 76 20 98 76 42 53 95 60 81 58 93
Sample Output:
98 95 93
42 37 81
53 20 76
58 60 76
Problem Analysis:
蛇形矩阵经典模型,用偏移量和方向取模来解决顺时针填数问题,首先确定行列大小,并且从大到小排序所有数字,然后循环填数即可。
Code
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
const int N = 10010;
int n;
int w[N];
int main()
{
cin >> n;
for (int i = 0; i < n; i ++ ) cin >> w[i];
sort(w, w + n, [](int x, int y) {
return x > y;
});
int r, c;
for (int i = 1; i <= n / i; i ++ ) // 不用求min,i增长,差距越来越小
if (n % i == 0)
{
r = n / i;
c = i;
}
vector<vector<int>> res(r, vector<int>(c));
int dx[] = {
-1, 0, 1, 0}, dy[] = {
0, 1, 0, -1};
// 当前横纵坐标 x, y
for (int i = 0, x = 0, y = 0, d = 1; i < n; i ++ )
{
res[x][y] = w[i];
int a = x + dx[d], b = y + dy[d];
if (a < 0 || a >= r || b < 0 || b >= c || res[a][b]) // 越界或者被占用
{
d = (d + 1) % 4;
a = x + dx[d], b = y + dy[d];
}
x = a, y = b;
}
for (int i = 0; i < r; i ++ )
{
cout << res[i][0];
for (int j = 1; j < c; j ++ )
cout << ' ' << res[i][j];
cout << endl;
}
return 0;
}