#1126. Eulerian Path【欧拉路径 / 欧拉回路】

原题链接

Problem Description:

In graph theory, an Eulerian path is a path in a graph which visits every edge exactly once. Similarly, an Eulerian circuit is an Eulerian path which starts and ends on the same vertex. They were first discussed by Leonhard Euler while solving the famous Seven Bridges of Konigsberg problem in 1736. It has been proven that connected graphs with all vertices of even degree have an Eulerian circuit, and such graphs are called Eulerian. If there are exactly two vertices of odd degree, all Eulerian paths start at one of them and end at the other. A graph that has an Eulerian path but not an Eulerian circuit is called semi-Eulerian. (Cited from https://en.wikipedia.org/wiki/Eulerian_path)

Given an undirected graph, you are supposed to tell if it is Eulerian, semi-Eulerian, or non-Eulerian.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N N N ( ≤ 500 \leq 500 500), and M M M, which are the total number of vertices, and the number of edges, respectively. Then M M M lines follow, each describes an edge by giving the two ends of the edge (the vertices are numbered from 1 to N N N).

Output Specification:

For each test case, first print in a line the degrees of the vertices in ascending order of their indices. Then in the next line print your conclusion about the graph – either Eulerian, Semi-Eulerian, or Non-Eulerian. Note that all the numbers in the first line must be separated by exactly 1 space, and there must be no extra space at the beginning or the end of the line.

Sample Input 1:

7 12
5 7
1 2
1 3
2 3
2 4
3 4
5 2
7 6
6 3
4 5
6 4
5 6

Sample Output 1:

2 4 4 4 4 4 2
Eulerian

Sample Input 2:

6 10
1 2
1 3
2 3
2 4
3 4
5 2
6 3
4 5
6 4
5 6

Sample Output 2:

2 4 4 4 3 3
Semi-Eulerian

Sample Input 3:

5 8
1 2
2 5
5 4
4 1
1 3
3 2
3 4
5 3

Sample Output 3:

3 3 4 3 3
Non-Eulerian

Problem Analysis:

前置知识:

了解了相关性质,本题就是一个模拟题,直接模拟即可,但需注意,欧拉图必须是连通图

Code

#include <iostream>
#include <algorithm>
#include <cstring>

using namespace std;

const int N = 510;

int n, m;
bool g[N][N], st[N];
int d[N];

int dfs(int u) // 返回从u出发能搜到多少个点
{
    
    
    st[u] = true;
    int res = 1;
    for (int i = 1; i <= n; i ++ )
        if (!st[i] && g[u][i]) // 如果连通
            res += dfs(i);
    return res;
}

int main()
{
    
    
    cin >> n >> m;
    for (int i = 0; i < m; i ++ )
    {
    
    
        int a, b;
        cin >> a >> b;
        g[a][b] = g[b][a] = true;
        ++ d[a], ++ d[b];
    }

    int cnt = dfs(1);

    for (int i = 1; i <= n; i ++ )  
    {
    
    
        cout << d[i];
        if (i != n) cout << ' ';
    }
    cout << endl;

    if (cnt == n)
    {
    
    
        int s = 0;
        for (int i = 1; i <= n; i ++ ) 
            if (d[i] & 1) 
                ++ s;
        
        if (s == 2) puts("Semi-Eulerian");
        else if (s == 0) puts("Eulerian");
        else puts("Non-Eulerian");
    }
    else puts("Non-Eulerian");

    return 0;   
}

猜你喜欢

转载自blog.csdn.net/geraltofrivia123/article/details/121049675