HDU-1061 Rightmost Digit (快速幂的应用)

HDU-1061 Rightmost Digit (快速幂的应用)

Rightmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Problem Description
Given a positive integer N, you should output the most right digit of N^N.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

Output
For each test case, you should output the rightmost digit of N^N.
 

Sample Input
 
  
2 3 4
 

Sample Output
 
  
7 6
Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
 

Author
Ignatius.L
 

Recommend
We have carefully selected several similar problems for you:   1021  1008  1019  1071  1108 

技巧 任意找一个小的取模的数(肯定是要大于想要取模的位数)将次方值降下来

#include<stdio.h>
long long p=1e3;
long long pow_mod(long long a,long long x)
{
	long long ans=1;               //p是取模的数
    long long base=a%p;
	while(x>0)
	{
       if((x&1)==1)
       ans=(ans*base)%p;     //if里的条件也可以写成x&1
	   base=base*base%p;
	   x=x>>1;
	}
	return ans;
}
int main()
{
    int t;
    long long n,ans;
    while(~scanf("%lld",&t))
    {
        while(t--)
        {
            scanf("%lld",&n);
            ans=pow_mod(n,n)%10;
            printf("%lld\n",ans);
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/xigongdali/article/details/80531982