hdu5375Gray code(dp)

Gray code

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 384    Accepted Submission(s): 216


Problem Description
The reflected binary code, also known as Gray code after Frank Gray, is a binary numeral system where two successive values differ in only onebit (binary digit). The reflected binary code was originally designed to prevent spurious output from electromechanical switches. Today, Gray codes are widely used to facilitate error correction in digital communications such as digital terrestrial television and some cable TV systems.

hdu5375Gray code(dp) - NatureRan - NatureRan


Now , you are given a binary number of length n including ‘0’ , ’1’ and ‘?’(? means that you can use either 0 or 1 to fill this position) and n integers(a1,a2,….,an) . A certain binary number corresponds to a gray code only. If the ith bit of this gray code is 1,you can get the point ai.
Can you tell me how many points you can get at most?

For instance, the binary number “00?0” may be “0000” or “0010”,and the corresponding gray code are “0000” or “0011”.You can choose “0000” getting nothing or “0011” getting the point a3 and a4.
 

Input
The first line of the input contains the number of test cases T.

Each test case begins with string with ‘0’,’1’ and ‘?’.

The next line contains n (1<=n<=200000) integers (n is the length of the string).

a1 a2 a3 … an (1<=ai<=1000)
 

Output
For each test case, output “Case #x: ans”, in which x is the case number counted from one,’ans’ is the points you can get at most
 

Sample Input
 
   
2 00?0 1 2 4 8 ???? 1 2 4 8
 

Sample Output
 
   
Case #1: 12 Case #2: 15
Hint
https://en.wikipedia.org/wiki/Gray_code http://baike.baidu.com/view/358724.htm
 
 
   

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
using namespace std;
int n,len;
char str[200005];
int arr[200005];
long long dp[200005][2];
int main(int argc, char *argv[])
{

int i,x;
scanf("%d",&n);
for(x=1;x<=n;x++){
scanf("%s",str);
len=strlen(str);
for(i=0;i<len;i++) scanf("%d",&arr[i]);
if(str[0]=='0') dp[0][0]=dp[0][1]=0;
if(str[0]=='1') dp[0][0]=dp[0][1]=arr[0];
if(str[0]=='?') dp[0][0]=0;dp[0][1]=arr[0];
for(i=1;i<len;i++){
if(str[i]=='?'){
if(str[i-1]=='?'){
dp[i][0]=max(dp[i-1][0],dp[i-1][1]+arr[i]);
dp[i][1]=max(dp[i-1][0]+arr[i],dp[i-1][1]);
}
if(str[i-1]=='0'){
dp[i][0]=dp[i-1][0];
dp[i][1]=dp[i-1][0]+arr[i];
}
if(str[i-1]=='1'){
dp[i][0]=dp[i-1][1]+arr[i];
dp[i][1]=dp[i-1][1];
}
}
else if(str[i]=='0'){
if(str[i-1]=='?'){
dp[i][0]=dp[i][1]=max(dp[i-1][0],dp[i-1][1]+arr[i]);
}
if(str[i-1]=='0'){
dp[i][0]=dp[i-1][0];
dp[i][1]=dp[i-1][0];
}
if(str[i-1]=='1'){
dp[i][0]=dp[i-1][1]+arr[i];
dp[i][1]=dp[i-1][1]+arr[i];
}
}
else if(str[i]=='1'){
if(str[i-1]=='?'){
dp[i][0]=dp[i][1]=max(dp[i-1][1],dp[i-1][0]+arr[i]);
}
if(str[i-1]=='0'){
dp[i][0]=dp[i-1][0]+arr[i];
dp[i][1]=dp[i-1][0]+arr[i];
}
if(str[i-1]=='1'){
dp[i][0]=dp[i-1][1];
dp[i][1]=dp[i-1][1];
}
}
}
printf("Case #%d: %lld\n",x,max(dp[len-1][0],dp[len-1][1]));
}
return 0;
}



猜你喜欢

转载自blog.csdn.net/nature_ran/article/details/79125332