POJ - 2385 Apple Catching DP 记忆化搜索 经典DP

It is a little known fact that cows love apples. Farmer John has two apple trees (which are conveniently numbered 1 and 2) in his field, each full of apples. Bessie cannot reach the apples when they are on the tree, so she must wait for them to fall. However, she must catch them in the air since the apples bruise when they hit the ground (and no one wants to eat bruised apples). Bessie is a quick eater, so an apple she does catch is eaten in just a few seconds. 

Each minute, one of the two apple trees drops an apple. Bessie, having much practice, can catch an apple if she is standing under a tree from which one falls. While Bessie can walk between the two trees quickly (in much less than a minute), she can stand under only one tree at any time. Moreover, cows do not get a lot of exercise, so she is not willing to walk back and forth between the trees endlessly (and thus misses some apples). 

Apples fall (one each minute) for T (1 <= T <= 1,000) minutes. Bessie is willing to walk back and forth at most W (1 <= W <= 30) times. Given which tree will drop an apple each minute, determine the maximum number of apples which Bessie can catch. Bessie starts at tree 1.
Input
* Line 1: Two space separated integers: T and W 

* Lines 2..T+1: 1 or 2: the tree that will drop an apple each minute.
Output
* Line 1: The maximum number of apples Bessie can catch without walking more than W times.
Sample Input
7 2
2
1
1
2
2
1
1
Sample Output
6
Hint
INPUT DETAILS: 

Seven apples fall - one from tree 2, then two in a row from tree 1, then two in a row from tree 2, then two in a row from tree 1. Bessie is willing to walk from one tree to the other twice. 

OUTPUT DETAILS: 

Bessie can catch six apples by staying under tree 1 until the first two have dropped, then moving to tree 2 for the next two, then returning back to tree 1 for the final two.      
 

有两棵APP树,编号为1,2.每一秒,这两棵APP树中的其中一棵会掉一个APP.每一秒,你可以选择在当前APP树下接APP,或者迅速移动到另外一棵APP树下接APP(移动时间可以忽略不计),但由于却乏锻炼,你最多移动W次.问在T秒内,你最多能收集多少个APP.假设你开始站在1号APP树下.


#include<iostream>
#include<cstdio>
#include<algorithm>
#include<map>
#include<set>
#include<cstring>
using namespace std;
const int len=1e3+3;
const int INF=0x3f3f3f3f;
#define ll long long
const ll mod=1e18;
int main()
{
	int n,m;
	while(cin>>n>>m)
	{
		int arr[len];
		for(int i=1;i<=n;++i)
		{
			cin>>arr[i];
			arr[i]--;
		}
		int dp[len][50]={};//前i秒,跳了j次的最大苹果数 
		for(int i=1;i<=n;++i)
		{
			dp[i][0]=dp[i-1][0]+(arr[i]==0);
			for(int j=1;j<=m;++j)
			{
				dp[i][j]=max(dp[i-1][j],dp[i-1][j-1])+((j&1)==arr[i]);
			}
		}
		int ans=0;
		for(int i=0;i<=m;++i)
			ans=max(ans,dp[n][i]);//取前n秒的最大值 
		cout<<ans<<endl;
	} 
}

猜你喜欢

转载自blog.csdn.net/hutwuguangrong/article/details/80298080