HDUOJ 1001

Sum Problem
Time Limit: 1000/500 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 548426 Accepted Submission(s): 139129

Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + … + n.

Input
The input will consist of a series of integers n, one integer per line.

Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.

Sample Input
1
100

Sample Output
1

5050

Author
DOOM III

#include <stdio.h>

int main(){   

     int i,a,j;double sum;   

      while(scanf("%d",&a)!=EOF)     {  
            sum=0;       

        for(j=1;j<=a;j++)        

        {             
               sum+=j;         
        } 


        printf("%.0lf\n\n",sum);    
       }    

        return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_41897234/article/details/80487943