A1002 A+B for Polynomials

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 … NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, …, K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < … < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 2 1.5 1 2.9 0 3.2

//本算法利用同一数组进行计算,较简便,满分
#include <stdio.h>
#define N 1001
int main(){
    float a[N] = { 0 };
    int k, e;
    float c;
    int cnt = 0;
    scanf("%d", &k);
    for (int i = 0; i < k; i++){
        scanf("%d %f", &e, &c);
        a[e] += c;
    }
    scanf("%d", &k);
    for (int i = 0; i < k; i++){
        scanf("%d %f", &e, &c);
        a[e] += c;
    }
    for (int i = 0; i < N; i++){
        if (a[i] != 0){
            cnt++;
        }
    }
    printf("%d", cnt);
    for (int i = N-1; i >= 0; i--){
        if (a[i] != 0){
            printf(" %d %.1f", i, a[i]);     //不必在最后一个数后加回车
        }
    }

    return 0;
}
//本算法利用三个数组,较繁琐,且有漏洞(哪位大神不吝指教,不胜感激~),23分
#include <stdio.h>
#define N 1001
int main(){
    int k1;
    scanf("%d", &k1);
    float a[N] = { 0 }, b[N] = { 0 };

    for (int i = 0; i < 2 * k1; i++){
        scanf("%f", &a[i]);
    }
    int k2;
    scanf("%d", &k2);
    for (int i = 0; i < 2 * k2; i++){
        scanf("%f", &b[i]);
    }

    float c[N] = { 0 };
    int i = 0, j = 0, k = 0;
    while (i < N - 1){
        if (a[i] == b[j]){
            if (a[i + 1] != 0 || b[j + 1] != 0){
                c[k] = a[i];
                c[k + 1] = a[i + 1] + b[j + 1];
                if (c[k + 1] != 0){
                    k += 2;
                }
                i += 2;
                j += 2;
            }
            else{
                break;
            }
        }
        else{
            if (a[i] < b[j]){
                c[k] = b[j];
                c[k + 1] = b[j + 1];
                j += 2;
            }
            else{
                c[k] = a[i];
                c[k + 1] = a[i + 1];
                i += 2;
            }
            k += 2;
        }
    }
    printf("%d ", k/2);
    for (int t = 0; t < k-1; t++){
        if (t % 2 == 0){
            printf("%d ", (int)c[t]);
        }
        else{
            printf("%.1f ", c[t]);
        }
    }
    printf("%.1f\n", c[k-1]);     //最后一行加回车
    return 0;
}

猜你喜欢

转载自blog.csdn.net/u013025421/article/details/52156606
今日推荐