2018 ACM-ICPC 中国大学生程序设计竞赛线上赛-B:Goldbach(JAVA判断质数)

Description:

Goldbach's conjecture is one of the oldest and best-known unsolved problems in number theory and all of mathematics. It states:

Every even integer greater than 2 can be expressed as the sum of two primes.

The actual verification of the Goldbach conjecture shows that even numbers below at least 1e14 can be expressed as a sum of two prime numbers. 

Many times, there are more than one way to represent even numbers as two prime numbers. 

For example, 18=5+13=7+11, 64=3+61=5+59=11+53=17+47=23+41, etc.

Now this problem is asking you to divide a postive even integer n (2<n<2^63) into two prime numbers.

Although a certain scope of the problem has not been strictly proved the correctness of Goldbach's conjecture, we still hope that you can solve it. 

If you find that an even number of Goldbach conjectures are not true, then this question will be wrong, but we would like to congratulate you on solving this math problem that has plagued humanity for hundreds of years.

Input:

The first line of input is a T means the number of the cases.

Next T lines, each line is a postive even integer n (2<n<2^63).

Output:

The output is also T lines, each line is two number we asked for.

T is about 100.

本题答案不唯一,符合要求的答案均正确

样例输入

1
8

样例输出

3 5

题目来源

2018 ACM-ICPC 中国大学生程序设计竞赛线上赛

思路:暴力枚举,判断2个加数是否是质数。JAVA中BigInteger中提供了判断质数的函数。
import java.util.*;
import java.math.*;
public class main {
    public static void main(String args[])
    {
    	Scanner cin=new Scanner(System.in);
    	int T=cin.nextInt();
    	while((T--)>0)
    	{
    		long n=cin.nextLong();
    		long x=n/2;
    		while(x>=2)
    		{
    			//判断x是否是质数,如果这个函数认为x是质数,那么发生错误的概率不会超过1/(2^100)
    			if(BigInteger.valueOf(x).isProbablePrime(100)&&BigInteger.valueOf(n-x).isProbablePrime(100))
    			{
    				System.out.println(x+" "+(n-x));
    				break;
    			}
    			x--;
    		}
    	}
    }
}

猜你喜欢

转载自blog.csdn.net/mitsuha_/article/details/80271725