Food Delivery (区间DP)

When we are focusing on solving problems, we usually prefer to stay in front of computers rather than go out for lunch. At this time, we may call for food delivery.

Suppose there are N people living in a straight street that is just lies on an X-coordinate axis. The ith person's coordinate is Xi meters. And in the street there is a take-out restaurant which has coordinates X meters. One day at lunchtime, each person takes an order from the restaurant at the same time. As a worker in the restaurant, you need to start from the restaurant, send food to the N people, and then come back to the restaurant. Your speed is V-1 meters per minute.

You know that the N people have different personal characters; therefore they have different feeling on the time their food arrives. Their feelings are measured by Displeasure Index. At the beginning, the Displeasure Index for each person is 0. When waiting for the food, the ith person will gain Bi Displeasure Index per minute.

If one's Displeasure Index goes too high, he will not buy your food any more. So you need to keep the sum of all people's Displeasure Index as low as possible in order to maximize your income. Your task is to find the minimal sum of Displeasure Index.

Input

The input contains multiple test cases, separated with a blank line. Each case is started with three integers N ( 1 <= N <= 1000 ), V ( V > 0), X ( X >= 0 ), then Nlines followed. Each line contains two integers Xi ( Xi >= 0 ), Bi ( Bi >= 0), which are described above.

You can safely assume that all numbers in the input and output will be less than 231- 1.

Please process to the end-of-file.

Output

For each test case please output a single number, which is the minimal sum of Displeasure Index. One test case per line.

Sample Input

5 1 0
1 1
2 2
3 3
4 4
5 5

Sample Output

55

题目大意:

在一个一维坐标轴上,有若干个点,已知餐厅的位置,以及外卖员的速度,不满意度为Bi*等待的时间,求外卖员从餐厅送到各个点的最小总不满意度。

可以将餐厅加进去并排列,以餐厅为中心,向外扩:

dp[i][j][0]:(需要将除了区间以内的数全部乘上这个差值)

dp[i+1][j][0]+(pre[i]+pre[n]-pre[j])*(a[i+1].x-a[i].x) 、dp[i+1][j][1]+(pre[i]+pre[n]-pre[j])*(a[j].x-a[i].x)

dp[i][j][1]:

dp[i][j-1][0]+(pre[i-1]+pre[n]-pre[j-1])*(a[j].x-a[i].x)、dp[i][j-1][1]+(pre[i-1]+pre[n]-pre[j-1])*(a[j].x-a[j-1].x)

#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
const int INF=0x3f3f3f3f;
long long dp[1005][1005][2],pre[1005];
int n,v,x;
struct p
{
    int x,b;
}a[1005];
bool cmp(p a,p b)
{
    return a.x<b.x;
}
int main()
{
    ios::sync_with_stdio(false);
    while(cin>>n>>v>>x)
    {
        memset(dp,INF,sizeof dp);
        for(int i=0;i<n;i++)
            cin>>a[i].x>>a[i].b;
        a[n].x=x,a[n].b=0;///将餐厅点加进去
        sort(a,a+n+1,cmp);
        int pos=0;///找到餐厅的位置
        for(int i=0;i<=n;i++)
            if(a[i].x==x&&a[i].b==0)
                pos=i;
        dp[pos][pos][0]=dp[pos][pos][1]=0;
        pre[0]=a[0].b;
        for(int i=1;i<=n;i++)///处理前缀和
            pre[i]=pre[i-1]+a[i].b;
        for(int i=pos;i>=0;i--)
            for(int j=pos;j<=n;j++)
            {
                if(i==j) continue;
                dp[i][j][0]=min(dp[i][j][0],dp[i+1][j][0]+(pre[i]+pre[n]-pre[j])*(a[i+1].x-a[i].x));///左,前左
                dp[i][j][0]=min(dp[i][j][0],dp[i+1][j][1]+(pre[i]+pre[n]-pre[j])*(a[j].x-a[i].x));///左,前右
                dp[i][j][1]=min(dp[i][j][1],dp[i][j-1][0]+(pre[i-1]+pre[n]-pre[j-1])*(a[j].x-a[i].x));///右,前左
                dp[i][j][1]=min(dp[i][j][1],dp[i][j-1][1]+(pre[i-1]+pre[n]-pre[j-1])*(a[j].x-a[j-1].x));///右,前右
            }
        cout<<v*min(dp[0][n][0],dp[0][n][1])<<'\n';///v代表的是每米花多少时间
    }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/zdragon1104/p/9175268.html