DP———6.两个状态之间的 处理

Tickets

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7196    Accepted Submission(s): 3659


Problem Description
Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible.
A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time.
Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full of appreciation for your help.
 
Input
There are N(1<=N<=10) different scenarios, each scenario consists of 3 lines:
1) An integer K(1<=K<=2000) representing the total number of people;
2) K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person;
3) (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together.
 
Output
For every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm.
 
Sample Input
2 2 20 25 40 1 8
 
Sample Output
08:00:40 am 08:00:08 am
#include<cstdio>
#include<algorithm>
#include<iostream>
using namespace std;
const int INF = 0x3f3f3f3f;
const int maxn = 2000+5;
int t[maxn];
int tt[maxn];
int dp[maxn][2];
int main() {
    int T;
    scanf("%d",&T);
    while(T--) {
        int n;
        scanf("%d",&n);
        for (int i=1; i<=n; i++) {
            scanf("%d",&t[i]);
            dp[i][0]=0;
            dp[i][1]=0;
        }
        for(int i=2; i<=n; i++) {
            scanf("%d",&tt[i]);
        }
        tt[1]=t[1];

        dp[0][0]=0;
        dp[0][1]=0;
        for(int i=1; i<=n; i++) {
            dp[i][0]=min(dp[i-1][0],dp[i-1][1])+t[i];

            if(i>1) {
                dp[i][1]=min(dp[i-2][0],dp[i-2][1])+tt[i];
            } else {
                dp[i][1]=t[i];
            }

        }
        int ans = min(dp[n][1], dp[n][0]);

        int h, m, s;
        h = 8 + ans/3600;
        ans %= 3600;
        m = ans/60;
        ans %= 60;
        s = ans;
        if(h > 12) {
            h %= 12;
            printf("%02d:%02d:%02d pm\n",h, m, s);
        } else {
            printf("%02d:%02d:%02d am\n",h, m, s);
        }

    }
}
View Code

猜你喜欢

转载自www.cnblogs.com/buerdepepeqi/p/9182459.html