1143. Lowest Common Ancestor


1143. Lowest Common Ancestor (30)

时间限制
200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

A binary search tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

Given any two nodes in a BST, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (<= 1000), the number of pairs of nodes to be tested; and N (<= 10000), the number of keys in the BST, respectively. In the second line, N distinct integers are given as the preorder traversal sequence of the BST. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line "LCA of U and V is A." if the LCA is found and A is the key. But if A is one of U and V, print "X is an ancestor of Y." where X is A and Y is the other node. If U or V is not found in the BST, print in a line "ERROR: U is not found." or "ERROR: V is not found." or "ERROR: U and V are not found.".

Sample Input:
6 8
6 3 1 2 5 4 8 7
2 5
8 7
1 9
12 -3
0 8
99 99
Sample Output:
LCA of 2 and 5 is 3.
8 is an ancestor of 7.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.


题意就是按照要求找到BST树中U和V点的最近公共祖先 并按照要求输出出来

我们可以直接遍历整个表 由于BST的先序序列 就是元素的插入顺序 也就是元素的深度优先搜索的顺序 我们可以直接扫描整个表 就相当于深度搜索整棵树 如果当前点符合输出条件就停下输出

但是后来一直错不知道为什么 最后参考了网上的代码才发现 原来即使找到了两个点的LCA 也要按照输入顺序 先输出U 再输出V

哎。。。这一个错找了好久好久 PAT果然对输入输出一点也不友好。。。

#include<bits/stdc++.h>
using namespace std;
int a[10010];
map<int,bool>Map;
int main()
{
    int n,m;
    scanf("%d%d",&n,&m);
    for(int i=1;i<=m;i++){ 
        scanf("%d",&a[i]);
        Map[a[i]]=1;
    }
    while(n--){
        int s,e;
        scanf("%d%d",&s,&e);
		bool fs=0,fe=0;
		fs = Map[s],fe = Map[e];
		if(fs==0&&fe==0)
			printf("ERROR: %d and %d are not found.\n",s,e);		       
		else if(fs!=0&&fe==0)
			printf("ERROR: %d is not found.\n",e); 
		else if(fs==0&&fe!=0)
			printf("ERROR: %d is not found.\n",s);        
        else{
        	int ss = s,ee=e;
        	s = min(ss,ee),e = max(ee,ss); 
        	for(int now = 1;now<=m;now++){
				if((s<a[now]&&e>a[now])){
					printf("LCA of %d and %d is %d.\n",ss,ee,a[now]);//就是这里输出如果是s,e 修改后的元素的输出 就会导致两个测试点出错
					break;
				}
				if(s==a[now]){
					printf("%d is an ancestor of %d.\n",s,e);
					break;
				}
				if(e==a[now]){
					printf("%d is an ancestor of %d.\n",e,s);
					break;
				}				
			} 
		}
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/qq_33859479/article/details/79664806