ZOJ 2305 C Looooops (扩展欧几里得模板题)

C Looooops

Time Limit: 2 Seconds      Memory Limit: 65536 KB

A Compiler Mystery: We are given a C-language style for loop of type

for (variable = A; variable != B; variable += C)
    statement;

I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2k) modulo 2k.

Input

The input consists of several instances. Each instance is described by a single line with four integers A, B, C, k separated by a single space. The integer k (1 <= k <= 32) is the number of bits of the control variable of the loop and A, B, C (0 <= A, B, C < 2k) are the parameters of the loop.

The input is finished by a line containing four zeros.

Output

The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the loop does not terminate.

Sample Input

3 3 2 16
3 7 2 16
7 3 2 16
3 4 2 16
0 0 0 0

Sample Output

0
2
32766
FOREVER


Source: Czech Technical University Open 2004

#include<iostream>
#include<algorithm>
#include<string>
#include<map>//int dx[4]={0,0,-1,1};int dy[4]={-1,1,0,0};
#include<set>//int gcd(int a,int b){return b?gcd(b,a%b):a;}
#include<vector>
#include<cmath>
#include<stack>
#include<string.h>
#include<stdlib.h>
#include<cstdio>
#define maxn 103
#define ll long long
#define INF 10000000
using namespace std;
//d=gcd(a,b)=ax+by,返回x,y;
long long x,y;
long long  exgcd(long long a,long long b)
{
    if(b==0)
    {
        x=1;
        y=0;
        return a;
    }
    long long d=exgcd(b,a%b),tmp=x;//顺序问题不能错
    x=y;
    y=tmp-a/b*y;
    return d;
}
int main()
{
    long long a,b,c,k;
    while(scanf("%lld%lld%lld%lld",&a,&b,&c,&k),a||b||c||k)
    {
        long long n=(long long )1<<k;
        long long d=exgcd(c,n);
        if((b-a)%d)
        {
            printf("FOREVER\n");
            continue;
        }
        long long t=n/d;
        x=(x*(b-a)/d%t+t)%t;
        printf("%lld\n",x);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_37451344/article/details/80717459