SW1
vlan batch 10 20
interface GigabitEthernet0/0/2
port link-type access
port default vlan 10
interface GigabitEthernet0/0/24
port link-type access
port default vlan 20
interface Vlanif10
ip address 192.168.1.1 255.255.255.0
interface Vlanif20
ip address 10.1.1.2 255.255.255.0
ip route-static 0.0.0.0 0.0.0.0 10.1.1.1
R2
interface GigabitEthernet0/0/0
ip address 10.1.1.1 255.255.255.0
ip route-static 0.0.0.0 0.0.0.0 10.0.0.1
ip route-static 192.168.1.0 255.255.255.0 10.1.1.2
acl 2000
rule permit source 192.168.1.0 0.0.0.255
rule permit source 10.1.1.0 0.0.0.255
interface GigabitEthernet0/0/1
ip address 10.0.0.88 255.255.255.0
nat outbound 2000