PAT 1032 挖掘机技术哪家强

https://pintia.cn/problem-sets/994805260223102976/problems/994805289432236032

为了用事实说明挖掘机技术到底哪家强,PAT组织了一场挖掘机技能大赛。现请你根据比赛结果统计出技术最强的那个学校。

输入格式:

输入在第1行给出不超过10^5^的正整数N,即参赛人数。随后N行,每行给出一位参赛者的信息和成绩,包括其所代表的学校的编号(从1开始连续编号)、及其比赛成绩(百分制),中间以空格分隔。

输出格式:

在一行中给出总得分最高的学校的编号、及其总分,中间以空格分隔。题目保证答案唯一,没有并列。

输入样例:

6
3 65
2 80
1 100
2 70
3 40
3 0

输出样例:

2 150

O(n)=O(n)

代码:
#include <bits/stdc++.h>

using namespace std;

const int maxn=1e5+10;
int a[maxn];

int main()
{
    int n;
    int maxx=0,first;
    scanf("%d",&n);
    for(int i=1; i<=n; i++)
    {
        int A,b;
        scanf("%d%d",&A,&b);
        a[A]+=b;
        if(a[A]>=maxx)
        {
            maxx=a[A];
           first=A;
        }
    }
    printf("%d %d",first,maxx);
    return 0;
}

  

猜你喜欢

转载自www.cnblogs.com/zlrrrr/p/9275461.html