PAT(A-LEVEL) 1001 A+B Format

1001 A+B Format

Calculate a + b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input

-1000000 9

Sample Output

-999,991

水题,但第一次木有AC
原因在于没有考虑1000000+1000000输出2,000,000这样的情况
输出comma的位置可由公式:j=n-3*k(k=1或2)来决定

  • n:数字长度,如2000000时,n=7
  • 当输出了j位数字后输出一个comma,比如2,000,000,就是输出了1或4位数字后输出一个comma

下面贴上AC代码:

#include<cstdio>
#include<cmath>
#define MAX 7
using namespace std;

int main()
{
    int a,b;        //分别是a,b两个数 
    int sum;        //a+b 
    int num[MAX];   //用于存放sum 
    int n=0;        //sum的长度 

    scanf("%d%d",&a,&b);
    sum=a+b;
    if(sum==0) printf("%d",sum);        //若和为0 直接输出0 
    else{
        if(sum<0) printf("-");
        sum=abs(sum);
        while(sum>=1){
            num[n]=sum%10;
            sum/=10;
            n++;
        }

        int j=1;    //当输出了n-3*k(k=1或2)个数时,输出一个comma 
        for(int i=n-1;i>=0;i--){
            printf("%d",num[i]);
            if(j==n-3*1 || j==n-3*2) printf(",");
            j++;
        }
    } 
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_29159273/article/details/53984308