HDU 1358 Period

做这个题前,依然需要引入两个公式:是否是循环节(i % (i - next[i]) == 0)和循环部分的长度(i - next[i])。

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A  K , that is A concatenated K times, for some string A. Of course, we also want to know the period K. 
InputThe input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it. 
OutputFor each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case. 
Sample Input
3
aaa
12
aabaabaabaab
0
Sample Output
Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4
题目要求找出输入字符串的每一个从str[0]开始的循环部分,然后输出这个循环部分的末尾和有几个循环体。所以先判断是否是循环节,然后再算循环部分的长度,所以循环体的个数就是(总长度/循环部分长度),然后就AC了。

#include <iostream>
#include <memory.h>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
const int maxn = 1000001;
int ne[maxn];
void getnext(char *a)
{
    int len = strlen(a);
    ne[0] = -1;
    int i=0, j=-1;
    while(i<len)
    {
        if(j==-1 || a[i] == a[j])
        {
            ne[++i] = ++j;
        }
        else
        {
            j = ne[j];
        }
    }
}
int main()
{
    char str[maxn];
    int i, j, n;
    int num = 1;
    memset(str, 0, sizeof(str));
    while(scanf("%d", &n) != EOF)
    {
        getchar();
        if(n == 0)
            break;
        memset(ne, 0, sizeof(ne));
        for(i=0; i<n; i++)
        {
            scanf("%c", &str[i]);
        }
        printf("Test case #%d\n", num);
        getnext(str);
        int sum;
        for(i=0; i<=n; i++)
        {
            if(i % (i-ne[i]) == 0 && i != 0 && ne[i] != 0)
            {
                sum = i/(i-ne[i]);
                cout << i << " " << sum << endl;
            }
        }
        num++;
        memset(str, 0, sizeof(str));
        cout << endl;
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/wangjunchengno2/article/details/79113853