poj 2104 K-th Number

理解自:(https://blog.csdn.net/tree__water/article/details/80090450)

You are working for Macrohard company in data structures department. After failing your previous task about key insertion you were asked to write a new data structure that would be able to return quickly k-th order statistics in the array segment.
That is, given an array a[1…n] of different integer numbers, your program must answer a series of questions Q(i, j, k) in the form: “What would be the k-th number in a[i…j] segment, if this segment was sorted?”
For example, consider the array a = (1, 5, 2, 6, 3, 7, 4). Let the question be Q(2, 5, 3). The segment a[2…5] is (5, 2, 6, 3). If we sort this segment, we get (2, 3, 5, 6), the third number is 5, and therefore the answer to the question is 5.
Input
The first line of the input file contains n — the size of the array, and m — the number of questions to answer (1 <= n <= 100 000, 1 <= m <= 5 000).
The second line contains n different integer numbers not exceeding 109 by their absolute values — the array for which the answers should be given.
The following m lines contain question descriptions, each description consists of three numbers: i, j, and k (1 <= i <= j <= n, 1 <= k <= j - i + 1) and represents the question Q(i, j, k).
Output
For each question output the answer to it — the k-th number in sorted a[i…j] segment.
Sample Input
7 3
1 5 2 6 3 7 4
2 5 3
4 4 1
1 7 3
Sample Output
5
6
3

//#include <bits/stdc++.h>
#include <cstdio>
#include <algorithm>
#include <iostream>
#define ls tree[rt].l,l,mid
#define rs tree[rt].r,mid+1,r
using namespace std;
typedef long long ll;
const int N=1e5+7;
struct node
{
    int l,r,val;
} tree[N*20];
int a[N],as[N],pos[N];
int cnt,root[N];
void update(int x,int &rt,int l,int r)
{
    tree[++cnt]=tree[rt];
    rt=cnt;
    tree[rt].val++;//已知子节点的个数
    if(l==r) return ;
    int mid=(l+r)>>1;
    if(x<=mid) update(x,ls);
    else update(x,rs);
}
int query(int L,int R,int k,int l,int r)
{
    if(l==r) return l;
    int tmp=tree[tree[R].l].val-tree[tree[L].l].val;
    int mid=(l+r)>>1;
    if(tmp>=k)return query(tree[L].l,tree[R].l,k,l,mid);
    else return query(tree[L].r,tree[R].r,k-tmp,mid+1,r);
}
int main()
{
    int n,m;
    scanf("%d%d",&n,&m);
    for(int i=1; i<=n; i++)
        scanf("%d",&a[i]),as[i]=a[i];
    sort(as+1,as+n+1);
    for(int i=1; i<=n; i++)
        pos[i]=lower_bound(as+1,as+n+1,a[i])-as;
    cnt=0;
    for(int i=1; i<=n; i++)
    {
        root[i]=root[i-1];
        update(pos[i],root[i],1,n);
    }
    while(m--)
    {
        int L,R,k;
        scanf("%d%d%d",&L,&R,&k);
        printf("%d\n",as[query(root[L-1],root[R],k,1,n)]);
    }
}

猜你喜欢

转载自blog.csdn.net/oinei/article/details/80184241