HDU 3635 Dragon Balls(带权并查集)

His country has N cities and there are exactly N dragon balls in the world. At first, for the ith dragon ball, the sacred dragon will puts it in the ith city. Through long years, some cities’ dragon ball(s) would be transported to other cities. To save physical strength WuKong plans to take Flying Nimbus Cloud, a magical flying cloud to gather dragon balls.
Every time WuKong will collect the information of one dragon ball, he will ask you the information of that ball. You must tell him which city the ball is located and how many dragon balls are there in that city, you also need to tell him how many times the ball has been transported so far.

Input
The first line of the input is a single positive integer T(0 < T <= 100).
For each case, the first line contains two integers: N and Q (2 < N <= 10000 , 2 < Q <= 10000).
Each of the following Q lines contains either a fact or a question as the follow format:
T A B : All the dragon balls which are in the same city with A have been transported to the city the Bth ball in. You can assume that the two cities are different.
Q A : WuKong want to know X (the id of the city Ath ball is in), Y (the count of balls in Xth city) and Z (the tranporting times of the Ath ball). (1 <= A, B <= N)

Output
For each test case, output the test case number formated as sample output. Then for each query, output a line with three integers X Y Z saparated by a blank space.

Sample Input
2
3 3
T 1 2
T 3 2
Q 2
3 4
T 1 2
Q 1
T 1 3
Q 1

Sample Output
Case 1:
2 3 0
Case 2:
2 2 1
3 3 2

题意:
‘T’ :将A集合全部放入 集合B
‘Q’ :询问 第ith在x集合;x集合中的元素个数;ith的移动次数

#ifdef WSM
#include <bits:stdc++.h>
#else
#include <bits/stdc++.h>
#endif
using namespace std;
const int N=1e4+7;
int f[N],cnt[N],hei[N];
int _find(int x)
{
    if(x!=f[x])
    {
        int tmp=f[x];//tmp为x的当前父亲节点
        f[x]=_find(f[x]);
        cnt[x]+=cnt[tmp];//将父亲节点加到子节点
    }
    return f[x];
}
int main()
{
    int t;
    scanf("%d",&t);
    for(int cas=1;cas<=t;cas++)
    {
        printf("Case %d:\n",cas);
        for(int i=0;i<N;i++)
            f[i]=i,hei[i]=1;
        memset(cnt,0,sizeof(cnt));
        int n,m;
        scanf("%d%d",&n,&m);
        for(int i=0;i<m;i++)
        {
            char ch;
            int a,b;
            getchar();
            scanf("%c",&ch);
            if(ch=='T')
            {
                scanf("%d%d",&a,&b);
                int fa=_find(a);
                int fb=_find(b);
                if(fa!=fb)
                {
                    f[fa]=fb;
                    hei[fb]+=hei[fa];//将a中元素加入b中,a清空
                    hei[fa]=0;
                    cnt[fa]=1;//if(fa!=fb) 说明变换之前不在一个集合,所以fa作为一个父亲节点,将fa连到fb,那么fa移动了一次 :cnt[fa]=1;
                }
            }
            else
            {
                scanf("%d",&a);
                int fa=_find(a);
                printf("%d %d %d\n",fa,hei[fa],cnt[a]);
            }
        }
    }
}

猜你喜欢

转载自blog.csdn.net/oinei/article/details/78067444