AMR11A - Magic Grid

Thanks a lot for helping Harry Potter in finding the Sorcerer's Stone of Immortality in October. Did we not tell you that it was just an online game ? uhhh! now here is the real onsite task for Harry. You are given a magrid S ( a magic grid ) having R rows and C columns. Each cell in this magrid has either a Hungarian horntail dragon that our intrepid hero has to defeat, or a flask of magic potion that his teacher Snape has left for him. A dragon at a cell (i,j) takes away |S[i][j]| strength points from him, and a potion at a cell (i,j) increases Harry's strength by S[i][j]. If his strength drops to 0 or less at any point during his journey, Harry dies, and no magical stone can revive him.

Harry starts from the top-left corner cell (1,1) and the Sorcerer's Stone is in the bottom-right corner cell (R,C). From a cell (i,j), Harry can only move either one cell down or right i.e., to cell (i+1,j) or cell (i,j+1) and he can not move outside the magrid. Harry has used magic before starting his journey to determine which cell contains what, but lacks the basic simple mathematical skill to determine what minimum strength he needs to start with to collect the Sorcerer's Stone. Please help him once again.

Input (STDIN):

The first line contains the number of test cases T. T cases follow. Each test case consists of R C in the first line followed by the description of the grid in R lines, each containing C integers. Rows are numbered 1 to R from top to bottom and columns are numbered 1 to C from left to right. Cells with S[i][j] < 0 contain dragons, others contain magic potions.

Output (STDOUT):

Output T lines, one for each case containing the minimum strength Harry should start with from the cell (1,1) to have a positive strength through out his journey to the cell (R,C).

Constraints:

1 ≤ T ≤ 5

2 ≤ R, C ≤ 500

-10^3 ≤ S[i][j] ≤ 10^3

S[1][1] = S[R][C] = 0

Sample Input:

3
2 3
0 1 -3
1 -2 0
2 2
0 1
2 0
3 4
0 -2 -3 1
-1 4 0 -2
1 -2 -3 0

扫描二维码关注公众号,回复: 2039919 查看本文章

Sample Output:

2
1
2

Explanation:

Case 1 : If Harry starts with strength = 1 at cell (1,1), he cannot maintain a positive strength in any possible path. He needs at least strength = 2 initially.

Case 2 : Note that to start from (1,1) he needs at least strength = 1.

题意:给你一个r*c的网格从(1,1)点出发,只能向右或者向下走,问你走到(r,c)点所需的最小初始能量,每经过一个格子当前的能量就就加上它的值,当前能量值不能小于等于零。

思路:因为我们要求最小的初始能量,如果正向dp时就要考虑当前积累能量的情况,所以不行,我们就逆向dp,因为它不用考虑路线能量的积累(后面的积累不能被前面用)。

#include<stdio.h>
#include<string.h>
#define INF 0x3fffffff
int dp[510][510];
int mp[510][510];
int max(int a,int b){
	if(a>b)
	return a;
	return b;
}
int min(int a,int b){
	if(a<b)
	return a;
	return b;
}
int main(){
	int t;
	int r,c,i,j;
	scanf("%d",&t);
	while(t--){
		scanf("%d%d",&r,&c);
		memset(dp,0,sizeof(dp));
		for(i=0;i<=r+1;i++)
		dp[i][c+1]=INF;
		for(i=0;i<=c+1;i++)
		dp[r+1][i]=INF;
		dp[r+1][c]=0;
		dp[r][c+1]=0;
		for(i=1;i<=r;i++){
			for(j=1;j<=c;j++)
			scanf("%d",&mp[i][j]);
		}
		for(i=r;i>0;i--){
			for(j=c;j>0;j--){
				dp[i][j]=max(1,min(dp[i+1][j],dp[i][j+1])-mp[i][j]);
				//printf("%d %d %d\n",i,j,dp[i][j]);	
			}
		}
		printf("%d\n",dp[1][1]);
	}
	return 0;
}

  

猜你喜欢

转载自www.cnblogs.com/cglongge/p/9288027.html