HDU Period 1358

Period

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11342    Accepted Submission(s): 5303


Problem Description
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K , that is A concatenated K times, for some string A. Of course, we also want to know the period K.
 

Input
The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.
 

Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
 

Sample Input
 
  
3 aaa 12 aabaabaabaab 0
 

Sample Output
 
  
Test case #1 2 2 3 3 Test case #2 2 2 6 2 9 3 12 4


没啥好注意的 用next数组搞一下就出来了
#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
const int MAX_N = 1000024;
int Next[MAX_N];
char  mo[MAX_N];
int n;
void getnext(){
    int i = 0,j = -1;
    while(i<n){
        if(j==-1||mo[i]==mo[j]) {
            ++i;
            ++j;
            Next[i] = j;
        }
        else j=Next[j];
    }
    return ;
}
int main(){
   int Case = 1;
   while(~scanf("%d",&n)&&n){
    printf("Test case #%d\n",Case++);
    scanf("%s",mo);
    Next[0] = -1;
    getnext();
    for(int i=1;i<=n;++i){
        if((i%(i-Next[i]))==0&&i/(i-Next[i])>1) printf("%d %d\n",i,i/(i-Next[i]));
    }
    printf("\n");
   }
    return 0;
}

 

猜你喜欢

转载自blog.csdn.net/heucodesong/article/details/80807384