HDU 3746 Cyclic Nacklace 简单KMP应用

Cyclic Nacklace

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 13197    Accepted Submission(s): 5504


Problem Description
CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of "HDU CakeMan", he wants to sell some little things to make money. Of course, this is not an easy task.

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl's fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls' lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet's cycle is 9 and its cyclic count is 2:

Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden.
CC is satisfied with his ideas and ask you for help.
 

Input
The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases.
Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by 'a' ~'z' characters. The length of the string Len: ( 3 <= Len <= 100000 ).
 

Output
For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.
 

Sample Input
 
  
3 aaa abca abcde
 

Sample Output
 
  
0 2 5
 

Author
possessor WC
 

Source
 

我们怎么分析这个问题呢?首先 我们可以简单应用Next数组求它的最短周期 那么问题很明了

如果长度%周期==0 且长度/周期>1说明这已经是个周期串了 不用你补

不然的话就要你补 周期-长度%周期的字符

简单AC

这题加个memset就WA不加就过 能过纯属评论区有人说

#include <cstdio>
#include <algorithm>
#include <cstring>
#include <iostream>
#include <cmath>
using namespace std;
#define dbg(x) cout<<#x<<" = "<< (x)<< endl
const int MAX_N = 100024;
int Next[MAX_N];
char mo[MAX_N];
int n2;
void getnext(){
    int i = 0,j=-1;
    while(i<n2){
        if(j==-1||mo[i]==mo[j]) {
            ++i;
            ++j;
            Next[i] = j;
        }
        else j = Next[j];
    }
    return;
}
int main(){
    int t;
    scanf("%d",&t);
    while(t--){
    //memset(mo,0,sizeof(mo));
    scanf("%s",mo);
    Next[0] = -1;
    n2 = strlen(mo);
    getnext();
    if((n2/(n2-Next[n2]))>1&&(n2%(n2-Next[n2]))==0) printf("0\n");
    else printf("%d\n",n2-Next[n2]-n2%(n2-Next[n2]));
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/heucodesong/article/details/80806993
今日推荐