【PAT 甲级】1001 A+B Format

1001 A+B Format (20)(20 分)

Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input

-1000000 9

Sample Output

-999,991

题目大意:求两个数的和,并用三位分节法表示结果

我的代码如下:

#include <iostream>
#include <string>
using namespace std;
int main()
{
	int a,b,sum,i=1,temp;
	int s[100000];
	cin>>a>>b;

	sum=a+b;
	if(sum==0)
	{//如果合为0,直接输出0
		cout<<'0';
		system("pause");
		return 0;
	}
	temp=sum;

	while(sum!=0)
	{//从个位开始逐位存入
		s[i]=sum%10;
		sum=sum/10;
		i++;
	}

	//输出
	if(temp<0)
	{
		cout<<'-';
	}
	for(int j=i-1;j>=1;j--)
	{
		if(j%3==0&&j!=i-1)
		{
			cout<<',';
		}
		cout<<abs(s[j]);
	}

	system("pause");
	return 0;
}

猜你喜欢

转载自blog.csdn.net/CrystalXueNing/article/details/81005238
今日推荐