POJ1088 滑雪

Michael喜欢滑雪百这并不奇怪, 因为滑雪的确很刺激。可是为了获得速度,滑的区域必须向下倾斜,而且当你滑到坡底,你不得不再次走上坡或者等待升降机来载你。Michael想知道载一个区域中最长底滑坡。区域由一个二维数组给出。数组的每个数字代表点的高度。下面是一个例子
 1  2  3  4 5

16 17 18 19 6

15 24 25 20 7

14 23 22 21 8

13 12 11 10 9

一个人可以从某个点滑向上下左右相邻四个点之一,当且仅当高度减小。在上面的例子中,一条可滑行的滑坡为24-17-16-1。当然25-24-23-...-3-2-1更长。事实上,这是最长的一条。
Input
输入的第一行表示区域的行数R和列数C(1 <= R,C <= 100)。下面是R行,每行有C个整数,代表高度h,0<=h<=10000。
Output
输出最长区域的长度。
Sample Input
5 5
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9
Sample Output
25

PS:比较经典的dp题、

#include <iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<string>
#include<map>
const int maxn= 1e3+5;
const int mod=1e9;
#define me(a) memset(a,0,sizeof(a))
#define ll long long
using namespace std;
int a[maxn][maxn],dp[maxn][maxn];
int fx[4][2]={0,1,0,-1,-1,0,1,0};
int m,n;
int check(int x,int y)
{
    if(x<1||y<1||x>m||y>n)
        return 0;
    return 1;
}
int dfs(int x,int y)
{
    if(!dp[x][y])
    {
        for(int i=0;i<4;i++)
        {
            int x1=x+fx[i][0];
            int y1=y+fx[i][1];
            if(check(x1,y1)&&a[x1][y1]<a[x][y])
               dp[x][y]=max(dp[x][y],dfs(x1,y1));
        }
        dp[x][y]++;
    }
    return dp[x][y];
}
int main()
{
    scanf("%d%d",&m,&n);
    for(int i=1;i<=m;i++)
        for(int j=1;j<=n;j++)
            scanf("%d",&a[i][j]);
        me(dp);
        int max=-1;
        for(int i=1;i<=m;i++)
            for(int j=1;j<=n;j++)
                if(max<dfs(i,j))
                    max=dfs(i,j);
    cout<<max<<endl;;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41292370/article/details/80987570