HDU1069 Monkey and Banana

A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food. 

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. 

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked. 

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks. 
InputThe input file will contain one or more test cases. The first line of each test case contains an integer n, 
representing the number of different blocks in the following data set. The maximum value for n is 30. 
Each of the next n lines contains three integers representing the values xi, yi and zi. 
Input is terminated by a value of zero (0) for n. 
OutputFor each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height". 
Sample Input
1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0
Sample Output
Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

PS:一道很不错的dp题,最后可以化为求和最大的和的子序列。因为长方体分六个面,所以每个长宽高都可以做其他两项,等于每个数都可以做长宽高,所以在输入的时候就进行处理,然后按长从小到大排序,如果长相等,宽就从小到大排序,最后这样找高的和最大的和的子序列。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct node
{
	int l,k,g;
};
int cmp(node a,node b)
{
	if(a.l==b.l)
		return a.k<b.k;
	return a.l<b.l;
}
int main()
{
	int n,ss=1;
	while(cin>>n&&n)
	{
		node a[200];
		int l,k,g;
		int len=0;
		for(int i=0;i<n;i++)
		{
			cin>>l>>k>>g;
			a[len].l=l,a[len].k=k,a[len++].g=g;
			a[len].l=l,a[len].k=g,a[len++].g=k;
			a[len].l=k,a[len].k=l,a[len++].g=g;
			a[len].l=k,a[len].k=g,a[len++].g=l;
			a[len].l=g,a[len].k=l,a[len++].g=k;
			a[len].l=g,a[len].k=k,a[len++].g=l;	
		}
		sort(a,a+len,cmp);
		int dp[200];
		memset(dp,0,sizeof(dp));
		//dp[0]=a[0].h;
		int sum=0;
		for(int i=0;i<len;i++)
		{
			int ma=0;
			for(int j=0;j<i;j++)
				if(a[i].l>a[j].l&&a[i].k>a[j].k)
					ma=max(ma,dp[j]);
			dp[i]=ma+a[i].g;
			if(sum<dp[i])
				sum=dp[i];
		}
		cout<<"Case "<<ss++<<": "<<"maximum height = ";
		cout<<sum<<endl;
	}
	return 0;
}


猜你喜欢

转载自blog.csdn.net/qq_41292370/article/details/80962783