N - Ubiquitous Religions 寒假练习2-N

来源:poj2524
There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in.

You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.
Input
The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.
Output
For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.
Sample Input
10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0
Sample Output
Case 1: 1
Case 2: 7
Hint
Huge input, scanf is recommended.
题意概括:
学校有很多宗教,先给出n对宗教相同的学生,问学校有几个宗教。
解题思路:
并查集问题,查找祖先数,把宗教相同的学生归并到编号较小的学生祖先上,最后查祖先数。
代码:

#include<stdio.h>
#include<string.h>
#define maxn 50500
int m,n;
int f[maxn];
void init();
void merge(int c,int d);
int find(int v);
int main()
{
    int t=0;
    while(scanf("%d%d",&m,&n),m||n)
    {
        int c=0,a,b;
        init();
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&a,&b);
            if(a!=b)
            {
                merge(a,b);
            }

        }
        for(int i=1;i<=m;i++)
        if(f[i]==i)c++;
        printf("Case %d: %d\n",++t,c);
    }
    return 0;
}
void init()
{
    for(int i=0;i<=m;i++)
    f[i]=i;
}
void merge(int c,int d)
{
    int a=find(c);
    int b=find(d);
    if(a>b)
    f[a]=b;
    else
    f[b]=a;
}
int find(int v)
{
    if(v!=f[v])//递归查找祖先,并压缩路径。 
    f[v]=find(f[v]);
    return f[v];
}

猜你喜欢

转载自blog.csdn.net/watestill/article/details/79250975