zoj-2100

Seeding

Time Limit: 2 Seconds       Memory Limit: 65536 KB

It is spring time and farmers have to plant seeds in the field. Tom has a nice field, which is a rectangle with n * m squares. There are big stones in some of the squares.

Tom has a seeding-machine. At the beginning, the machine lies in the top left corner of the field. After the machine finishes one square, Tom drives it into an adjacent square, and continues seeding. In order to protect the machine, Tom will not drive it into a square that contains stones. It is not allowed to drive the machine into a square that been seeded before, either.

Tom wants to seed all the squares that do not contain stones. Is it possible?


Input

The first line of each test case contains two integers n and m that denote the size of the field. (1 < n, m < 7) The next n lines give the field, each of which contains m characters. 'S' is a square with stones, and '.' is a square without stones.

Input is terminated with two 0's. This case is not to be processed.


Output

For each test case, print "YES" if Tom can make it, or "NO" otherwise.


Sample Input

4 4
.S..
.S..
....
....
4 4
....
...S
....
...S
0 0


Sample Output

YES

NO

简单dfs,遍历整个矩阵,若遍历到的“.”的个数和矩阵的点的个数相等说明YES

#include<bits/stdc++.h>
using namespace std;

int d[4][2]={{0,1},{0,-1},{-1,0},{1,0}};
int num,f,cnt;
int n,m;
char s[10][10];
int a[10][10];
void dfs(int x,int y)
{
	if(num==cnt)
	{
		f=1;
		return ;
	}
	for(int i=0; i<4; i++)
	{
		int dx=x+d[i][0];
		int dy=y+d[i][1];
		if(s[dx][dy]=='.'&&a[dx][dy]==0&&0<=dx&&dx<n&&dy>=0&&dy<m)
		{
			a[dx][dy]=1;
			num++;
			dfs(dx,dy);
			num--;
			a[dx][dy]=0;
		}
	}
	return ;
	
}
int main()
{

	while(~scanf("%d%d",&n,&m),n)
	{
		for(int i=0; i<n; i++)scanf(" %s",s[i]);
		cnt=0;
		for(int i=0; i<n; i++)
		{
			for(int j=0; j<m; j++)
			{
				if(s[i][j]=='.')cnt++;
			}
		}
		memset(a,0,sizeof(a));
		a[0][0]=1;
		f=0;
		num=1;
		dfs(0,0);
		if(f)puts("YES");
		else puts("NO");
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/yu121380/article/details/81032824
ZOJ